Tutte le ultime notizie tradotte da archlinux.org

Messaggio13 maggio 2012, 11:03 - PHP aggiornato alla versione 5.4 #122096

PHP è stato aggiornato alla sua ultima major release 5.4. Il changelog dell'upstream può essere trovato all'indirizzo http://www.php.net/ChangeLog-5.php e, una guida alla migrazione dettagliata, all'indirizzo http://www.php.net/migration54. Inoltre, sono stati apportati i seguenti cambiamenti.

La patch e l'estensione suhosin sono state rimosse. Per saperne di più sui motivi di questa decisione: http://www.pierre-schmitz.com/php-5-4-1-in-suhosin-out/. Se stavate usando l'estensione suhosin, rimuovete il pacchetto php-suhosin, poiché non è più compatibile con PHP 5.4.
Notate che l'API dell'estensione è stata cambiata. Se state usando estensioni di terze parti che non sono nei nostri repository, dovete almeno ricompilarle o aggiornarle ad una versione compatibile.
Il modulo json adesso è compilato in PHP stesso. Quindi, rimuovete la direttiva extension=json.so dal vostro file php.ini.
L'estensione gd è stata compilata con il supporto webp, usando la libreria libvpx.

Assicuratevi di apportare tutti i cambiamenti del nuovo file php.ini alla vostra copia locale oppure di aggiustare il nuovo php.ini secondo le vostre necessità. Qualora si presentassero dei problemi durante l'utilizzo dell'estensione APC, provate ad installare il pacchetto php-xcache che è stato aggiunto al repository.

Ultimo ma non meno importante: se state utilizzando dei vecchi script, assicuratevi che non si basino su caratteristiche come "Safe Mode" o "Magic Quotes". Queste caratteristiche sono state rimosse e, quindi, un aggiornamento a PHP 5,4 si tradurrà in gravi falle di sicurezza.

Pierre Schmitz
Arch Linux Developer
Avatar utente
Giovanni
Developer
 
Messaggi: 2462
Iscritto il: 26 agosto 2007, 16:33
Località: Livorno
Top

Torna a Notizie

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron