[Risolto] Client YouTube

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
Zar Marco
Arciere Provetto
Messaggi: 405
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

[Risolto] Client YouTube

Messaggio da Zar Marco » 1 agosto 2017, 5:09

Ciao ragazzi, spero di non sbagliare ad aprire questo thread. Ho da poco installato i3wm, mi ci trovo bene, ottimo wm. Detto questo, sto seguendo alcuni corsi sul tubi, di vario genere, ed ho bisogno di prendere appunti. Ora, utilizzando il browser il video o lo metto full screen, oppure se non lo massimizzo, rimane piccolo, e vado male a leggere quello che che viene scritto nel video. Sto cercando un qualche programma che mi faccia da client YouTube, come un applicazione. Ho visto che c'è ne sono molte, quindi vi chiedo un consiglio, qual'è la migliore per il mio scopo? Massimizzare su browser lo escludo, perché in contemporanea vorrei tenere aperto anche un editor di testo. Grazie a tutti
Ultima modifica di Zar Marco il 22 novembre 2017, 3:46, modificato 1 volta in totale.
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Avatar utente
smlb
Amministratore
Messaggi: 535
Iscritto il: 17 aprile 2013, 12:40
Architettura: x86_64 (64bit)
Località: /dev/null
Contatta:

Re: Client YouTube

Messaggio da smlb » 23 ottobre 2017, 12:36

Ciao, ho spostato in Software & Librerie.

Potresti tranquillamente usare mpv, e` molto comodo, soprattutto per il tuo use-case.
Prima di aprire thread ed effettuare altre azioni sul forum, leggere attentamente: forum etiquette

Consultare la wiki prima di postare sul forum - inserire sempre informazioni attinenti alle problematiche riscontrate

Avatar utente
TheSaint
Robin Hood
Messaggi: 6962
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Client YouTube

Messaggio da TheSaint » 23 ottobre 2017, 19:14

Penso che dovresti usare un programma che ti scarica i video che sei interessato a seguire. Poi hai la possibilità di aggiustare la dimensione della finestra come ti pare e senza contorni del browser, anche con mpv.
F the saint
10 anni da questo forum ;)

gaglioffo
Arciere
Messaggi: 233
Iscritto il: 11 maggio 2016, 21:06

Re: Client YouTube

Messaggio da gaglioffo » 23 ottobre 2017, 20:09

io ogni tanto uso SMTube:

Codice: Seleziona tutto

# pacman -S smtube
se vuoi un editor di testo sempre sopra, clicca la finestra e seleziona "Sempre in primo piano" o "Livello->Sempre sopra" (dipende dal wm che usi).

VenereNera
Little John
Messaggi: 766
Iscritto il: 20 dicembre 2012, 19:50

Re: Client YouTube

Messaggio da VenereNera » 23 ottobre 2017, 22:25

Se usi Videolan vlc, lo apri, ctrl + n, incolli il link nella casella e clicchi su riproduci, oppure apri un terminale e lanci vlc seguito dal link del video.

Avatar utente
smlb
Amministratore
Messaggi: 535
Iscritto il: 17 aprile 2013, 12:40
Architettura: x86_64 (64bit)
Località: /dev/null
Contatta:

Re: Client YouTube

Messaggio da smlb » 24 ottobre 2017, 12:36

VenereNera ha scritto:Se usi Videolan vlc, lo apri, ctrl + n, incolli il link nella casella e clicchi su riproduci, oppure apri un terminale e lanci vlc seguito dal link del video.
Che e` come usare mpv praticamente :P
Prima di aprire thread ed effettuare altre azioni sul forum, leggere attentamente: forum etiquette

Consultare la wiki prima di postare sul forum - inserire sempre informazioni attinenti alle problematiche riscontrate

VenereNera
Little John
Messaggi: 766
Iscritto il: 20 dicembre 2012, 19:50

Re: Client YouTube

Messaggio da VenereNera » 24 ottobre 2017, 13:25

Non lo uso mpv pur avendo mplayer installato e sicuramente è possibile anche con mplayer. :P

Zar Marco
Arciere Provetto
Messaggi: 405
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Re: Client YouTube

Messaggio da Zar Marco » 24 ottobre 2017, 15:39

Ciao e grazie a tutti, sto provando mpv, provo anche gli altri, però intanto devo capire come salvarli offline, cioè come poter scaricare una playlist

Con VLC ottengo questo errore

Codice: Seleziona tutto

┌─[saul@archBook] - [~] - [2017-10-24 03:46:52]
└─[0] <> vlc
VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[000055bd4b85f398] core libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
[000055bd4b9aef98] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[000055bd4b9aef98] skins2 interface error: cannot instantiate qt4 dialogs provider
[000055bd4b9aef98] [cli] lua interface: Listening on host "*console".
VLC media player 2.2.6 Umbrella
Command Line Interface initialized. Type `help' for help.
> ^C[000055bd4b9aef98] [cli] lua interface error: Error loading script /usr/lib/vlc/lua/intf/cli.luac: lua/intf/modules/host.lua:279: Interrupted.
Con smtube questo

Codice: Seleziona tutto

┌─[saul@archBook] - [~] - [2017-10-24 03:47:13]
└─[0] <> smtube               
smtube: error while loading shared libraries: /usr/lib/libQt5Script.so.5: file too short
Eh eh almeno mpv funziona eh eh
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

VenereNera
Little John
Messaggi: 766
Iscritto il: 20 dicembre 2012, 19:50

Re: Client YouTube

Messaggio da VenereNera » 24 ottobre 2017, 17:30

Per vlc dovresti verificare di aver installato i pacchetti lua e qt4.
Per smtube dovresti verificare la libreria libQt5Script. Se il programma cerca la versione /usr/lib/libQt5Script.so.5 mentre tu possiedi la /usr/lib/libQt5Script.so.4 oppure 6 (tanto per far esempio), ecco che ricevi l' errore.

Codice: Seleziona tutto

$ ldd /usr/lib/libQt5Script.*
Puoi momentaneamente creare un link che punta alla versione in uso.

Zar Marco
Arciere Provetto
Messaggi: 405
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Re: Client YouTube

Messaggio da Zar Marco » 24 ottobre 2017, 18:22

VenereNera ha scritto:Per vlc dovresti verificare di aver installato i pacchetti lua e qt4.
Per smtube dovresti verificare la libreria libQt5Script. Se il programma cerca la versione /usr/lib/libQt5Script.so.5 mentre tu possiedi la /usr/lib/libQt5Script.so.4 oppure 6 (tanto per far esempio), ecco che ricevi l' errore.

Codice: Seleziona tutto

$ ldd /usr/lib/libQt5Script.*
Puoi momentaneamente creare un link che punta alla versione in uso.
ok grazie, questo mi si allaccia con un'altra problematica che ho nell'installazione di plasma, ora provvedo ad eliminare e reinstallare glib
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Zar Marco
Arciere Provetto
Messaggi: 405
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Re: Client YouTube

Messaggio da Zar Marco » 22 novembre 2017, 3:45

Ok, metto risolto in questo post, visto che mi trovo bene con mpv. Software indubbiamente comodo
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Rispondi