[Risolto] Jack audio su Asus 551Jm non funzionante dopo aggiornamento

Problemi e discussioni inerenti ai PC portatili e ai loro accessori
Rispondi
awar
Novello Arciere
Messaggi: 40
Iscritto il: 1 marzo 2016, 16:47
Architettura: x86_64 (64bit)

[Risolto] Jack audio su Asus 551Jm non funzionante dopo aggiornamento

Messaggio da awar » 7 agosto 2017, 7:41

Salve, dopo aggiornamento, uno dei tanti

Codice: Seleziona tutto

sudo pacman -Syu
è un piccolo

Codice: Seleziona tutto

--force
purtroppo non mi funziona più il jack delle cuffie. E' importante per me che il jack funzioni perché è l'unico modo che ho per ascoltare l'audio. Non so se il problema è stato forzare un conflitto che tra l'altro per la fretta non mi sono preoccupato di vedere o questo non c'entri niente con il jack.
Di seguito vi mostro alcuni comandi di verifica presi dal wiki e da altri forum in inglese dove speravo di trovare soluzioni che però con me non hanno funzionato:

Codice: Seleziona tutto

[awar@archli ~]$ lsmod | grep snd
snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek    73728  1
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
snd_hda_intel          36864  8
snd_hda_codec         106496  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           65536  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm                86016  5 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_timer              28672  1 snd_pcm
snd                    69632  23 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd

Codice: Seleziona tutto

[awar@archli ~]$ alsactl init
alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "HDA-Intel" "Intel Haswell HDMI" "HDA:80862807,80860101,00100000" "0x8086" "0x2010"
Hardware is initialized using a generic method

Codice: Seleziona tutto

cat /etc/modprobe.d/alsa-base.conf
cat: /etc/modprobe.d/alsa-base.conf: File o directory non esistente
E su quest'ultimo vedo qualcosa di strano :roll:

Ho provato anche l'installazione di Jack e Jack2 ma non ho risolto anche avviando jack_control start.

I valori di alsa sono settati correttamente, almeno stando a quanto vedo in alsamixer:
Immagine

Poi ho provato ad avviare qjackctl nella speranza che magari, visto che non so usarlo, poteva in automatico trovare e sistemare la cosa
Immagine

Ho anche verificato dalla wiki di Arch questo settaggio:

Codice: Seleziona tutto

...you may want to prevent it from spawning automatically with X and taking over from JACK.

Edit /etc/pulse/client.conf, uncomment "autospawn" and set it to "no":

;autospawn = yes
autospawn = no
Altro comando che potrebbe dare più informazioni ai più addentrati e poco nabbi come me :D

Codice: Seleziona tutto

lspci -vvvv | grep -A 10 -i audio; amixer; aplay -l; lsmod | grep -i snd
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
	Subsystem: Intel Corporation Device 2010
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 38
	Region 0: Memory at f7a14000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

--
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
	Subsystem: ASUSTeK Computer Inc. Device 177d
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 37
	Region 0: Memory at f7a10000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC668 Analog [ALC668 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
snd_seq_dummy          16384  0
snd_seq                57344  1 snd_seq_dummy
snd_seq_device         16384  1 snd_seq
snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek    73728  1
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
snd_hda_intel          36864  6
snd_hda_codec         106496  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           65536  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm                86016  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_timer              28672  2 snd_seq,snd_pcm
snd                    69632  22 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd
amixer

Codice: Seleziona tutto

amixer
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
aplay -L

Codice: Seleziona tutto

null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
hdmi:CARD=HDMI,DEV=0
    HDA Intel HDMI, HDMI 0
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=1
    HDA Intel HDMI, HDMI 1
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=2
    HDA Intel HDMI, HDMI 2
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=3
    HDA Intel HDMI, HDMI 3
    HDMI Audio Output
sysdefault:CARD=PCH
    HDA Intel PCH, ALC668 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC668 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC668 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC668 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC668 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC668 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC668 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC668 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
Ultima info, perché poi non so più cosa postare:

Codice: Seleziona tutto

 cat /etc/modprobe.d/sound.conf; cat /etc/modprobe.d/modprobe.conf
cat: /etc/modprobe.d/sound.conf: File o directory non esistente
cat: /etc/modprobe.d/modprobe.conf: File o directory non esistente
Grazie per la pazienza che avrete nel leggere sto papiro ma la mia intenzione era quella di riuscire a darvi quante più info possibili.
Ultima modifica di awar il 7 agosto 2017, 15:44, modificato 1 volta in totale.

awar
Novello Arciere
Messaggi: 40
Iscritto il: 1 marzo 2016, 16:47
Architettura: x86_64 (64bit)

Re: Jack audio su Asus 551Jm non funzionante dopo aggiornamento

Messaggio da awar » 7 agosto 2017, 15:44

Al momento sembra funzionare dopo aver visto e rivisto la wiki nell'attesa di una risposta, aver seguito questo step e aver riavviato. Quindi metto risolto nella speranza di non dover modificare nuovamente.

Grazie a tutti comunque

Rispondi