[Risolto] Non riesco ad aggiornare (lungo)

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
Avatar utente
apaz
Newbie
Messaggi: 8
Iscritto il: 17 marzo 2015, 15:31
Architettura: x86_64 (64bit)

[Risolto] Non riesco ad aggiornare (lungo)

Messaggio da apaz » 17 febbraio 2017, 14:32

Salve, è da una settimana che con il comando

Codice: Seleziona tutto

# pacman -Syu
mi dice che non ci sono aggiornamenti. Ma aggiornamenti ci sono e non capisco perchè non li trova (per es. sqlite, nvidia378, mesa17, ecc).
Facendo

Codice: Seleziona tutto

# pacman -Syyu
mi ha trovato alcuni pacchetti più nuovi di quelli presenti nei repository:
[root@arch-paz paz]# pacman -Syyu
:: Sincronizzazione dei database in corso...
core è aggiornato
extra è aggiornato
community è aggiornato
multilib è aggiornato
archlinuxfr è aggiornato
:: Aggiornamento del sistema in corso...
attenzione: ffmpeg: la versione installata (1:3.2.4-1) è più recente di quella presente in extra (1:3.2.2-2)
attenzione: ffmpeg2.8: la versione installata (2.8.11-1) è più recente di quella presente in extra (2.8.9-2)
attenzione: file: la versione installata (5.30-1) è più recente di quella presente in core (5.29-1)
attenzione: grep: la versione installata (3.0-1) è più recente di quella presente in core (2.27-1)
attenzione: pacman-mirrorlist: la versione installata (20170211-1) è più recente di quella presente in core (20170201-1)
attenzione: pcre: la versione installata (8.40-1) è più recente di quella presente in core (8.39-2)
attenzione: python2-psutil: la versione installata (5.1.3-1) è più recente di quella presente in community (5.1.2-1)
attenzione: python2-pyodbc: la versione installata (4.0.5-1) è più recente di quella presente in community (4.0.3-1)
attenzione: sed: la versione installata (4.4-1) è più recente di quella presente in core (4.3-1)
attenzione: shared-mime-info: la versione installata (1.8-1) è più recente di quella presente in extra (1.7-1)
attenzione: xorg-server: la versione installata (1.19.1-2) è più recente di quella presente in extra (1.19.1-1)
attenzione: xorg-server-common: la versione installata (1.19.1-2) è più recente di quella presente in extra (1.19.1-1)
non ci sono aggiornamenti disponibili
Notare che non ho mai attivato i repository di [testing] né installato programmi al di fuori di pacman o AUR.
Ho dovuto disinstallare e reinstallare i relativi pacchetti attualmente presenti e adesso non da più i messaggi di "attenzione" ma comunque continua a dire che non ci sono aggiornamenti disponibili. Ho reinstallato più volte "mirrorlist"; ho fatto la manutenzione di pacman con paccache ecc; ho cercato nel wiki e in google senza trovare niente; nessuno sembra avere un problema simile.
Devo dire però che i repository sono raggiungibili perchè cercando di installare un qualsiasi pacchetto, l'operazione va a buon fine.
Ah, dimenticavo. il LOG di pacman non riporta errori, per lui gli aggiornamenti sono in regola.
Sapete aiutarmi su come rimediare al problema?
Ultima modifica di apaz il 18 febbraio 2017, 10:15, modificato 1 volta in totale.

Avatar utente
TheSaint
Robin Hood
Messaggi: 6895
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Non riesco ad aggiornare (lungo)

Messaggio da TheSaint » 17 febbraio 2017, 16:17

Dipende dal fatto che hai cambiato server. Forse quello che usi non è aggiornato.
Prova usare reflector
F the saint
10 anni da questo forum ;)

Avatar utente
Dusty
Arciere Provetto
Messaggi: 563
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: Non riesco ad aggiornare (lungo)

Messaggio da Dusty » 17 febbraio 2017, 20:05

apaz ha scritto:Ho reinstallato più volte "mirrorlist"
Reinstallare mirrorlist non ha alcuna utilità, perchè è solo un elenco di potenziali server teoricamente a disposizione.
Cioè un elenco di definizioni tutte commentate e quindi inattive.
Dopo l'installazione, quali hai attivato?
Qui trovi l'elenco completo e lo stato di aggiornamento:
https://www.archlinux.org/mirrors/status/
Nota che, per esempio,
http://archlinux.openlabto.org/archlinux/
è out-of-sync.

Avatar utente
apaz
Newbie
Messaggi: 8
Iscritto il: 17 marzo 2015, 15:31
Architettura: x86_64 (64bit)

Re: [Risolto] Non riesco ad aggiornare (lungo)

Messaggio da apaz » 18 febbraio 2017, 10:22

Non conoscevo Reflector; grazie della dritta.
Comunque ho commentato "openlab" e ora funziona tutto. Mi sembrava di averlo già provato la scorsa settimana e continuava a non aggiornare. Ma oggi funziona e così metto [Risolto].
Avevo attivi tutti e 5 i server italiani e ora ho disattivato "openlab". A questo proposito ho una curiosità: è meglio avere solo server italiani o magarai conviene qualche "straniero" ma più veloce?
Ringrazio entrambi e vi saluto.
Andrea

Avatar utente
Dusty
Arciere Provetto
Messaggi: 563
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: [Risolto] Non riesco ad aggiornare (lungo)

Messaggio da Dusty » 18 febbraio 2017, 11:12

apaz ha scritto:è meglio avere solo server italiani o magarai conviene qualche "straniero" ma più veloce?
Hai letto bene il wiki?
https://wiki.archlinux.org/index.php/mirrors
Credo che sia inutile metterne tanti.
Se ho capito bene, pacman non sta a ragionare sulla lista che gli hai passato, ma scarica dal primo che risponde.
Il server "straniero" può servire se quelli nazionali sono pochi.
Comunque, credo che questa ricerca frenetica del server più veloce sia fondamentalmente inutile.
Tanto per cominciare, la velocità di risposta cambia nel tempo, e quindi dovresti tornare di continuo a rivalutare.
E alla fine tutta questa fatica si traduce in un risparmio di una manciata di secondi.
Ne vale la pena?

Avatar utente
TheSaint
Robin Hood
Messaggi: 6895
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Non riesco ad aggiornare (lungo)

Messaggio da TheSaint » 18 febbraio 2017, 19:35

apaz ha scritto:Non conoscevo Reflector
Non serve segnare solo quelli italiani. Con reflector puoi scegliere tra i più veloci o i più aggiornati (e qualche altra opzione).
Poi pacman comincia sempre dal primo della lista, se fallisce passa ai successivi.
F the saint
10 anni da questo forum ;)

Rispondi